Tuesday, January 31, 2012

PPOE

Dalam jaringan , Protokol Point-to-Point (PPP) adalah data link protokol yang umum digunakan dalam membangun koneksi langsung antara dua node jaringan . It can provide connection authentication , transmission encryption (using ECP , RFC 1968 ), and compression . Hal ini dapat menyediakan koneksi otentikasi , transmisi enkripsi (menggunakan ECP , RFC 1968 ), dan kompresi .

PPP is used over many types of physical networks including serial cable , phone line , trunk line , cellular telephone , specialized radio links, and fiber optic links such as SONET . PPP digunakan di banyak jenis jaringan fisik termasuk kabel serial , line telepon , trunk line , telepon selular , radio link khusus, dan serat optik link seperti SONET . PPP is also used over Internet access connections (now marketed as "broadband"). Internet service providers (ISPs) have used PPP for customer dial-up access to the Internet , since IP packets cannot be transmitted over a modem line on their own, without some data link protocol. PPP juga digunakan melalui akses internet koneksi (sekarang dipasarkan sebagai "broadband"). penyedia layanan Internet (ISP) telah menggunakan PPP untuk pelanggan dial-up akses ke internet , karena paket IP tidak dapat dikirimkan melalui modem garis pada mereka sendiri, tanpa beberapa protokol data link. Two encapsulated forms of PPP, Point-to-Point Protocol over Ethernet (PPPoE) and Point-to-Point Protocol over ATM (PPPoA), are used most commonly by Internet Service Providers (ISPs) to establish a Digital Subscriber Line (DSL) Internet service connection with customers. Dua bentuk dikemas PPP, Point-to-Point Protocol over Ethernet (PPPoE) dan Point-to-Point Protocol atas ATM (PPPoA), yang paling sering digunakan oleh Internet Service Provider (ISP) untuk mendirikan Digital Subscriber Line (DSL) layanan koneksi internet dengan pelanggan.

PPP is commonly used as a data link layer protocol for connection over synchronous and asynchronous circuits, where it has largely superseded the older Serial Line Internet Protocol (SLIP) and telephone company mandated standards (such as Link Access Protocol, Balanced (LAPB) in the X.25 protocol suite). PPP biasanya digunakan sebagai data link layer protokol untuk koneksi melalui sinkron dan asinkron sirkuit, di mana sebagian besar telah digantikan yang lebih tua Baris Internet Protocol Serial (SLIP) dan perusahaan telepon standar diamanatkan (seperti Link Access Protocol, Balanced (LAPB) dalam X.25 protocol suite). PPP was designed to work with numerous network layer protocols, including Internet Protocol (IP), TRILL , Novell's Internetwork Packet Exchange (IPX), NBF and AppleTalk . PPP dirancang untuk bekerja dengan berbagai lapisan jaringan protokol, termasuk Internet Protocol (IP), getar , Novell Internetwork Packet Exchange (IPX), NBF dan AppleTalk .

Contents Isi [hide]
1 Description 1 Deskripsi
1.1 Automatic self configuration 1.1 Konfigurasi otomatis diri
1.2 Multiple network layer protocols 1,2 Beberapa protokol jaringan lapisan
1.3 Looped link detection 1,3 deteksi link yang dilingkarkan
2 PPP Configuration Options 2 PPP Konfigurasi Opsi
3 PPP frame 3 PPP bingkai
3.1 Structure of a PPP frame 3.1 Struktur frame PPP
3.2 Encapsulation 3.2 Enkapsulasi
4 PPP line activation and phases PPP 4 baris aktivasi dan fase
5 PPP over several links 5 PPP over beberapa link
5.1 Multilink PPP 5.1 Multilink PPP
5.2 Multiclass PPP 5.2 Multiclass PPP
6 PPP and tunnels 6 PPP dan terowongan
6.1 Derived protocols 6.1 Berasal protokol
6.2 PPP as a layer 2 protocol between both ends of a tunnel 6.2 PPP sebagai protokol 2 lapisan antara kedua ujung terowongan
7 RFCs 7 RFC
8 See also 8 Lihat juga
9 References 9 Referensi
10 External links 10 Pranala luar


[ edit ] Description [ sunting ] Deskripsi PPP and TCP/IP protocol stack PPP dan TCP / IP protocol stack Application Aplikasi FTP FTP SMTP SMTP HTTP HTTP … ... DNS DNS … ...
Transport Transportasi TCP TCP UDP UDP
Internet Internet IP IP IPv6 IPv6
Network access Jaringan akses PPP PPP
PPPoE PPPoE PPPoA PPPoA
Ethernet Ethernet ATM ATM

PPP was designed somewhat after the original HDLC specifications. PPP dirancang agak setelah asli HDLC spesifikasi. The designers of PPP included many additional features that had been seen only in proprietary data-link protocols up to that time. Para desainer dari PPP termasuk fitur tambahan yang telah dilihat hanya dalam kepemilikan data-link protokol sampai saat itu.

RFC 2516 describes Point-to-Point Protocol over Ethernet (PPPoE) as a method for transmitting PPP over Ethernet that is sometimes used with DSL . RFC 2364 describes Point-to-Point Protocol over ATM (PPPoA) as a method for transmitting PPP over ATM Adaptation Layer 5 (AAL5), which is also a common alternative to PPPoE used with DSL. RFC 2516 menjelaskan Point-to-Point Protocol over Ethernet (PPPoE) sebagai metode untuk transmisi PPP over Ethernet yang kadang-kadang digunakan dengan DSL . RFC 2364 menjelaskan Point-to-Point Protocol atas ATM (PPPoA) sebagai metode untuk transmisi PPP over ATM Adaptation Layer 5 (AAL5), yang juga merupakan alternatif yang umum untuk PPPoE digunakan dengan DSL.

PPP is specified in RFC 1661. PPP ditentukan dalam RFC 1661.

[ edit ] Automatic self configuration [ sunting ] Konfigurasi otomatis diri Link Control Protocol (LCP) initiates and terminates connections gracefully, allowing hosts to negotiate connection options. Link Control Protocol (LCP) inisiat dan berakhir koneksi anggun, memungkinkan host untuk menegosiasikan pilihan koneksi. It is an integral part of PPP, and is defined in the same standard specification. Ini adalah bagian integral dari PPP, dan didefinisikan dalam spesifikasi standar yang sama. LCP provides automatic configuration of the interfaces at each end (such as setting datagram size, escaped characters, and magic numbers) and for selecting optional authentication. LCP menyediakan konfigurasi otomatis dari antarmuka pada setiap akhir (seperti pengaturan datagram ukuran, melarikan diri karakter, dan nomor sihir) dan untuk memilih otentikasi opsional. The LCP protocol runs on top of PPP (with PPP protocol number 0xC021) and therefore a basic PPP connection has to be established before LCP is able to configure it. Protokol LCP berjalan di atas PPP (dengan nomor protokol PPP 0xC021) dan oleh karena itu sambungan PPP dasar harus dibentuk sebelum LCP dapat mengkonfigurasinya.

RFC 1994 describes Challenge-handshake authentication protocol (CHAP), which is preferred for establishing dial-up connections with ISPs. RFC 1994 menjelaskan Tantangan-jabat tangan protokol otentikasi (CHAP), yang lebih disukai untuk membangun koneksi dial-up dengan ISP. Although deprecated, Password authentication protocol (PAP) is still sometimes used. Meski usang, Sandi protokol otentikasi (PAP) masih kadang-kadang digunakan.

Another option for authentication over PPP is Extensible Authentication Protocol (EAP) described in RFC 2284 . Pilihan lain untuk otentikasi melalui PPP adalah Extensible Authentication Protocol (EAP) dijelaskan dalam RFC 2284 .

After the link has been established, additional network ( layer 3 ) configuration may take place. Setelah link telah ditetapkan, jaringan (tambahan lapisan 3 konfigurasi) dapat terjadi. Most commonly, the Internet Protocol Control Protocol (IPCP) is used, although Internetwork Packet Exchange Control Protocol (IPXCP) and AppleTalk Control Protocol (ATCP) were once very popular. [ citation needed ] Internet Protocol Version 6 Control Protocol (IPv6CP) will see extended use in the future, when IPv6 replaces IPv4 's position as the dominant layer-3 protocol. Paling umum, yang Internet Protocol Control Protocol (IPCP) digunakan, meskipun Internetwork Packet Exchange Control Protocol (IPXCP) dan AppleTalk Control Protocol (ATCP) pernah sangat populer [. rujukan? ] Internet Protocol Version 6 Control Protocol (IPv6CP) akan melihat diperpanjang digunakan di masa depan, saat IPv6 akan menggantikan IPv4 posisi 's sebagai protokol lapisan-3 yang dominan.

[ edit ] Multiple network layer protocols [ sunting ] Beberapa protokol lapisan jaringan PPP architecture PPP arsitektur IP IP
LCP LCP CHAP PAP EAP CHAP PAP EAP IPCP IPCP
PPP encapsulation PPP enkapsulasi
HDLC -like Framing HDLC seperti Framing PPPoE PPPoE PPPoA PPPoA
RS-232 RS-232 POS POS Ethernet Ethernet ATM ATM
SONET/SDH SONET / SDH

PPP permits multiple network layer protocols to operate on the same communication link. PPP memungkinkan protokol jaringan multiple layer untuk beroperasi pada link komunikasi yang sama. For every network layer protocol used, a separate Network Control Protocol (NCP) is provided in order to encapsulate and negotiate options for the multiple network layer protocols. Untuk setiap protokol lapisan jaringan yang digunakan, terpisah Network Control Protocol (NCP) disediakan dalam rangka untuk membungkus dan menegosiasikan opsi untuk beberapa protokol lapisan jaringan. It negotiates network-layer information, eg network address or compression options, after the connection has been established. Ini negosiasi lapisan jaringan informasi, alamat jaringan atau opsi kompresi misalnya, setelah sambungan telah ditetapkan.

For example, Internet Protocol (IP) uses the IP Control Protocol ( IPCP ), and Internetwork Packet Exchange (IPX) uses the Novell IPX Control Protocol ( IPX/SPX ). Sebagai contoh, Internet Protocol (IP) menggunakan Control Protokol IP ( IPCP ), dan Internetwork Packet Exchange (IPX) menggunakan Novell IPX Control Protocol ( IPX / SPX ). NCPs include fields containing standardized codes to indicate the network layer protocol type that the PPP connection encapsulates. NCP termasuk bidang yang berisi kode standar untuk menunjukkan jenis protokol lapisan jaringan yang koneksi PPP merangkum.

[ edit ] Looped link detection [ sunting ] deteksi link yang dilingkarkan PPP detects looped links using a feature involving magic numbers . PPP mendeteksi link dilingkarkan menggunakan fitur yang melibatkan nomor ajaib . When the node sends PPP LCP messages, these messages may include a magic number. Ketika node mengirim pesan PPP LCP, pesan ini mungkin termasuk angka ajaib. If a line is looped, the node receives an LCP message with its own magic number, instead of getting a message with the peer's magic number. Jika sebuah garis melingkar, node menerima pesan LCP dengan nomor sihir sendiri, bukannya mendapatkan pesan dengan nomor sihir peer.

[ edit ] PPP Configuration Options [ sunting ] Konfigurasi PPP Pilihan The previous section introduced the use of LCP options to meet specific WAN connection requirements. Bagian sebelumnya memperkenalkan penggunaan pilihan LCP untuk memenuhi persyaratan tertentu koneksi WAN. PPP may include the following LCP options: PPP mungkin termasuk pilihan LCP berikut:

Authentication - Peer routers exchange authentication messages. Otentikasi - rekan bertukar pesan otentikasi router. Two authentication choices are Password Authentication Protocol (PAP) and Challenge Handshake Authentication Protocol (CHAP). Dua pilihan otentikasi Otentikasi Sandi Protocol (PAP) dan Challenge Handshake Authentication Protocol (CHAP). Authentication is explained in the next section. Otentikasi dijelaskan dalam bagian berikutnya.
Compression - Increases the effective throughput on PPP connections by reducing the amount of data in the frame that must travel across the link. Kompresi - Meningkatkan throughput efektif pada koneksi PPP dengan mengurangi jumlah data dalam frame yang harus perjalanan di link. The protocol decompresses the frame at its destination. Protokol decompress frame di tempat tujuan. See RFC 1962 for more details. Lihat RFC 1962 untuk rincian lebih lanjut.
Error detection - Identifies fault conditions. Kesalahan deteksi - Mengidentifikasi kondisi kesalahan. The Quality and Magic Number options help ensure a reliable, loop-free data link. Kualitas dan pilihan Nomor Sihir membantu memastikan yang handal, loop-free data link. The Magic Number field helps in detecting links that are in a looped-back condition. Bidang Jumlah Sihir membantu dalam mendeteksi link yang berada dalam kondisi melingkar-kembali. Until the Magic-Number Configuration Option has been successfully negotiated, the Magic-Number must be transmitted as zero. Sampai Opsi Magic-Nomor Konfigurasi telah berhasil dinegosiasikan, Magic-Nomor harus dikirimkan sebagai nol. Magic numbers are generated randomly at each end of the connection. Nomor ajaib dihasilkan secara acak pada setiap akhir dari koneksi.
Multilink - Provides load balancing several interfaces used by PPP through Multilink PPP (see below). Multilink - Menyediakan interface load balancing beberapa digunakan oleh PPP melalui Multilink PPP (lihat di bawah).
[ edit ] PPP frame [ sunting ] PPP bingkai [ edit ] Structure of a PPP frame [ sunting ] Struktur frame PPP Name Nama Number of bytes Jumlah byte Description Deskripsi
Protocol Protokol 1 or 2 1 atau 2 setting of protocol in data field pengaturan protokol di bidang data
Information Informasi variable (0 or more) variabel (0 atau lebih) datagram datagram
Padding Lapisan variable (0 or more) variabel (0 atau lebih) optional padding opsional bantalan

The Protocol field indicates the type of payload packet (eg LCP , NCP , IP , IPX , AppleTalk , etc.). Bidang Protokol menunjukkan jenis paket payload (misalnya LCP , NCP , IP , IPX , AppleTalk , dll).

The Information field contains the PPP payload; it has a variable length with a negotiated maximum called the Maximum Transmission Unit . Bidang Informasi berisi muatan PPP, tetapi memiliki panjang variabel dengan maksimal dinegosiasikan disebut Maximum Transmission Unit . By default, the maximum is 1500 octets . Secara default, maksimal adalah 1500 oktet . It might be padded on transmission; if the information for a particular protocol can be padded, that protocol must allow information to be distinguished from padding. Mungkin empuk pada transmisi, jika informasi untuk protokol tertentu bisa empuk, protokol yang harus memungkinkan informasi harus dibedakan dari padding.

[ edit ] Encapsulation [ sunting ] Enkapsulasi PPP frames are encapsulated in a lower-layer protocol that provides framing and may provide other functions such as a checksum to detect transmission errors. PPP frame dikemas dalam sebuah protokol yang lebih rendah-layer yang menyediakan framing dan dapat menyediakan fungsi lain seperti checksum untuk mendeteksi kesalahan transmisi. PPP on serial links is usually encapsulated in a framing similar to HDLC , described by IETF RFC 1662 . PPP pada link serial biasanya dikemas dalam membingkai mirip dengan HDLC , digambarkan oleh IETF RFC 1662 .

Name Nama Number of bytes Jumlah byte Description Deskripsi
Flag Bendera 1 1 indicates frame's begin or end menunjukkan mulai frame atau mengakhiri
Address Alamat 1 1 broadcast address alamat broadcast
Control Kontrol 1 1 control byte byte kontrol
Protocol Protokol 1 or 2 1 atau 2 setting of protocol in information field pengaturan protokol di bidang informasi
Information Informasi variable (0 or more) variabel (0 atau lebih) datagram datagram
Padding Lapisan variable (0 or more) variabel (0 atau lebih) optional padding opsional bantalan
FCS FCS 2 (or 4) 2 (atau 4) error check periksa kesalahan

The Flag field is present when PPP with HDLC-like framing is used. Bidang Bendera hadir ketika PPP dengan HDLC seperti framing digunakan.

The Address and Control fields always have the value hex FF (for "all stations") and hex 03 (for "unnumbered information"), and can be omitted whenever PPP LCP Address-and-Control-Field-Compression (ACFC) is negotiated. Bidang Alamat dan Kontrol selalu memiliki nilai hex FF (untuk "semua stasiun") dan hex 03 (untuk "informasi tak terhitung"), dan dapat dihilangkan jika PPP LCP Alamat-dan-Control-Lapangan-Kompresi (ACFC) yang dinegosiasikan .

The Frame Check Sequence (FCS) field is used for determining whether an individual frame has an error. Para urutan Frame Check (FCS) bidang digunakan untuk menentukan apakah sebuah frame individu memiliki kesalahan. It contains a checksum computed over the frame to provide basic protection against errors in transmission. Ini berisi checksum dihitung atas bingkai untuk memberikan perlindungan dasar terhadap kesalahan dalam transmisi. This is a CRC code similar to the one used for other layer two protocol error protection schemes such as the one used in Ethernet. Ini adalah CRC kode yang mirip dengan yang digunakan untuk lainnya dua protokol skema perlindungan lapisan kesalahan seperti yang digunakan dalam Ethernet. According to RFC 1662 , it can be either 16 bits (2 bytes) or 32 bits (4 bytes) in size (default is 16 bits - Polynomial x 16 + x 12 + x 5 + 1). Menurut RFC 1662 , hal itu dapat berupa 16 bit (2 byte) atau 32 bit (4 byte) dalam ukuran (default adalah 16 bit - x Polinomial 16 + x 12 + 5 + 1 x).

The FCS is calculated over the Address, Control, Protocol, Information and Padding fields after the message have been escaped. FCS dihitung selama Alamat, Kontrol, Protokol, Informasi dan bidang Padding setelah pesan telah melarikan diri.

[ edit ] PPP line activation and phases [ sunting ] PPP baris aktivasi dan fase

A diagram depicting the phases of PPP according to RFC 1661 . Sebuah diagram yang menggambarkan fase PPP sesuai dengan RFC 1661 . The phases of the Point to Point Protocol according to RFC 1661 are listed below: Fase Point to Point Protocol sesuai dengan RFC 1661 tercantum di bawah ini:

Link Dead . Dead Link. This phase occurs when the link fails, or one side has been told not to connect (eg a user has finished his or her dialup connection.) Fase ini terjadi ketika link gagal, atau satu sisi telah diberitahu untuk tidak terhubung (misalnya pengguna telah selesai koneksi dialup nya.)
Link Establishment Phase . Tahap Pembentukan hubungan. This phase is where Link Control Protocol negotiation is attempted. Fase ini adalah tempat Link Control Protocol negosiasi dicoba. If successful, control goes either to the authentication phase or the Network-Layer Protocol phase, depending on whether authentication is desired. Jika berhasil, kontrol pergi baik ke fase otentikasi atau fase Protokol Jaringan-Layer, tergantung pada apakah otentikasi yang diinginkan.
Authentication Phase . Tahap otentikasi. This phase is optional. Fase ini adalah opsional. It allows the sides to authenticate each other before a connection is established. Hal ini memungkinkan pihak untuk mengotentikasi satu sama lain sebelum sambungan dibuat. If successful, control goes to the network-layer protocol phase. Jika berhasil, kontrol pergi ke fase protokol lapisan jaringan.
Network-Layer Protocol Phase . Jaringan-Layer Protocol Fase. This phase is where each desired protocols' Network Control Protocols are invoked. Fase ini adalah dimana setiap protokol yang diinginkan ' Jaringan Control Protokol dipanggil. For example, IPCP is used in establishing IP service over the line. Sebagai contoh, IPCP digunakan dalam membangun layanan IP melewati garis. Data transport for all protocols which are successfully started with their network control protocols also occurs in this phase. Transportasi data untuk semua protokol yang berhasil dimulai dengan protokol kontrol mereka jaringan juga terjadi pada fase ini. Closing down of network protocols also occur in this phase. Menutup protokol jaringan juga terjadi pada fase ini.
Link Termination Phase . Pemutusan hubungan Tahap. This phase closes down this connection. Fase ini menutup down koneksi ini. This can happen if there is an authentication failure, if there are so many checksum errors that the two parties decide to tear down the link automatically, if the link suddenly fails, or if the user decides to hang up his connection. Hal ini dapat terjadi jika ada kegagalan otentikasi, jika ada kesalahan checksum begitu banyak bahwa kedua pihak memutuskan untuk meruntuhkan link secara otomatis, jika link tiba-tiba gagal, atau jika pengguna memutuskan untuk menutup sambungan nya.
[ edit ] PPP over several links [ sunting ] PPP over beberapa link [ edit ] Multilink PPP [ sunting ] Multilink PPP Multilink PPP (also referred to as MLPPP , MP , MPPP , MLP , or Multilink) provides a method for spreading traffic across multiple distinct PPP connections. Multilink PPP (juga disebut sebagai MLPPP, MP, MPPP, MLP, atau Multilink) menyediakan sebuah metode untuk menyebarkan lalu lintas di beberapa sambungan PPP berbeda. It is defined in RFC 1990 . Hal ini didefinisikan dalam RFC 1990 . It can be used, for example, to connect a home computer to an Internet Service Provider using two traditional 56k modems, or to connect a company through two leased lines. Hal ini dapat digunakan, misalnya, untuk menghubungkan komputer rumah ke Internet Service Provider menggunakan dua modem 56k tradisional, atau untuk menghubungkan perusahaan melalui dua leased line.

On a single PPP line frames cannot arrive out of order, but this is possible when the frames are divided among multiple PPP connections. Pada baris frame PPP tunggal tidak dapat tiba rusak, tapi ini adalah mungkin ketika frame dibagi antara beberapa koneksi PPP. Therefore Multilink PPP must number the fragments so they can be put in the right order again when they arrive. Oleh karena itu Multilink PPP harus nomor fragmen sehingga mereka dapat dimasukkan ke dalam urutan yang benar lagi ketika mereka tiba.

Multilink PPP is an example of a link aggregation technology. Multilink PPP adalah contoh dari sebuah agregasi link teknologi. Cisco IOS Release 11.1 and later supports Multilink PPP. Cisco IOS 11.1 Lepaskan dan kemudian mendukung Multilink PPP.

[ edit ] Multiclass PPP [ sunting ] Multiclass PPP With PPP, one cannot establish several simultaneous distinct PPP connections over a single link. Dengan PPP, seseorang tidak dapat membangun koneksi simultan beberapa yang berbeda PPP melalui link tunggal.

That's not possible with Multilink PPP either. Itu tidak mungkin dengan Multilink PPP baik. Multilink PPP uses contiguous numbers for all the fragments of a packet, and as a consequence it is not possible to suspend the sending of a sequence of fragments of one packet in order to send another packet. Multilink PPP menggunakan nomor berdekatan untuk semua fragmen dari sebuah paket, dan sebagai akibatnya tidak mungkin untuk menangguhkan pengiriman urutan fragmen satu paket untuk mengirim paket lain. This prevents from running Multilink PPP multiple times on the same links. Hal ini untuk mencegah dari berjalan Multilink PPP beberapa kali pada link yang sama.

Multiclass PPP is a kind of Multilink PPP where each "class" of traffic uses a separate sequence number space and reassembly buffer. Multiclass PPP adalah jenis Multilink PPP mana masing-masing "kelas" dari lalu lintas menggunakan nomor urutan yang terpisah ruang dan reassembly penyangga. Multiclass PPP is defined in RFC 2686 . Multiclass PPP didefinisikan dalam RFC 2686 .

[ edit ] PPP and tunnels [ sunting ] PPP dan terowongan Simplified OSI protocol stack for an example SSH +PPP tunnel Sederhana OSI stack protokol untuk contoh SSH terowongan + PPP Application Aplikasi FTP FTP SMTP SMTP HTTP HTTP … ... DNS DNS … ...
Transport Transportasi TCP TCP UDP UDP
Network Jaringan IP IP
Data Link Data Link PPP PPP
Application Aplikasi SSH SSH
Transport Transportasi TCP TCP
Network Jaringan IP IP
Data Link Data Link Ethernet Ethernet ATM ATM
Physical Fisik Cables, NICs, and so on Kabel, NIC, dan sebagainya

[ edit ] Derived protocols [ sunting ] protokol Berasal PPTP is a form of PPP between two hosts via GRE using encryption ( MPPE ) and compression ( MPPC ). PPTP merupakan bentuk PPP antara dua host melalui GRE menggunakan enkripsi ( MPPE ) dan kompresi ( MPPC ).

[ edit ] PPP as a layer 2 protocol between both ends of a tunnel [ sunting ] PPP sebagai protokol 2 lapisan antara kedua ujung terowongan Many protocols can be used to tunnel data over IP networks. Banyak protokol dapat digunakan untuk terowongan data melalui jaringan IP. Some of them, like SSL , SSH , or L2TP create virtual network interfaces and give the impression a direct physical connections between the tunnel endpoints. Beberapa dari mereka, seperti SSL , SSH , atau L2TP membuat maya antarmuka jaringan dan memberikan kesan sebuah koneksi fisik langsung antara titik akhir terowongan. On a Linux host for example, these interfaces would be called tun0 . Pada Linux host untuk contoh, interface ini akan disebut tun0.

As there are only two endpoints on a tunnel, the tunnel is a point-to-point connection and PPP is a natural choice as a data link layer protocol between the virtual network interfaces. Karena hanya ada dua endpoint pada terowongan, terowongan koneksi point-to-point dan PPP adalah pilihan yang alami sebagai protokol data link lapisan antara antarmuka jaringan virtual. PPP can assign IP addresses to these virtual interfaces, and these IP addresses can be used, for example, to route between the networks on both sides of the tunnel. PPP dapat menetapkan alamat IP untuk antarmuka ini virtual, dan ini alamat IP dapat digunakan, misalnya, untuk rute antara jaringan di kedua sisi terowongan.

IPsec in tunneling mode does not create virtual physical interfaces at the end of the tunnel, since the tunnel is handled directly by the TCP/IP stack. L2TP can be used to provide these interfaces, this technique is called L2TP/IPsec. IPsec pada mode tunnelling tidak menciptakan antarmuka fisik virtual di ujung terowongan, karena terowongan ditangani langsung oleh TCP / IP stack. L2TP dapat digunakan untuk menyediakan antarmuka ini, teknik ini disebut L2TP/IPsec. In this case too, PPP provides IP addresses to the extremities of the tunnel. Dalam kasus ini juga, PPP menyediakan alamat IP untuk ekstremitas terowongan.

[ edit ] RFCs [ sunting ] RFC PPP is defined in RFC 1661 (The Point-to-Point Protocol, July 1994). RFC 1547 (Requirements for an Internet Standard Point-to-Point Protocol, December 1993) provides historical information about the need for PPP and its development. PPP didefinisikan dalam RFC 1661 (Protokol Point-to-Point, Juli 1994). RFC 1547 (Persyaratan Internet Protocol Point-to-Point Standar, Desember 1993) memberikan informasi historis tentang perlunya PPP dan perkembangannya. A series of related RFCs have been written to define how a variety of network control protocols-including TCP/IP , DECnet , AppleTalk , IPX , and others-work with PPP. Serangkaian RFC terkait telah ditulis untuk menentukan bagaimana berbagai protokol-termasuk kontrol jaringan TCP / IP , DECnet , AppleTalk , IPX , dan lain-lain-bekerja dengan PPP.

RFC 1661 , Standard 51, The Point-to-Point Protocol (PPP) RFC 1661 , Standar 51, Point-to-Point Protocol (PPP)
RFC 1662 , Standard 51, PPP in HDLC-like Framing RFC 1662 , Standar 51, PPP di HDLC seperti Framing
RFC 1717 , The PPP Multilink Protocol (MP) (obsoleted by RFC 1990 ) RFC 1717 , Multilink PPP Protocol (MP) (usang oleh RFC 1990 )
RFC 1990 , The PPP Multilink Protocol (MP) RFC 1990 , Multilink PPP Protocol (MP)
RFC 1994 , PPP Challenge Handshake Authentication Protocol (CHAP) RFC 1994 , PPP Tantangan Handshake Authentication Protocol (CHAP)
RFC 2686 , The Multi-Class Extension to Multi-Link PPP RFC 2686 , Perluasan Multi-Kelas ke Multi-Link PPP
RFC 2153 , Informational, PPP Vendor Extensions RFC 2153 , Informational, PPP Ekstensi Penjual
RFC 2284 , PPP Extensible Authentication Protocol (EAP) RFC 2284 , PPP Extensible Authentication Protocol (EAP)
RFC 2615 , PPP over SONET/SDH RFC 2615 , PPP over SONET / SDH
RFC 2687 , Proposed Standard, PPP in a Real-time Oriented HDLC-like Framing RFC 2687 , Standar Usulan, PPP dalam Framing Real-time seperti HDLC Berorientasi
RFC 5072 , IP Version 6 over PPP RFC 5072 , IP Versi 6 di PPP
RFC 5172 , Negotiation for IPv6 Datagram Compression Using IPv6 Control Protocol RFC 5172 , Negosiasi untuk Kompresi Datagram IPv6 IPv6 Menggunakan Control Protocol
[ edit ] See also [ sunting ] Lihat juga Extensible Authentication Protocol Extensible Authentication Protocol
Hayes command set Hayes perintah set
Link Access Procedure for Modems (LAPM) Link Access Procedure untuk Modem (LAPM)
SLIP an earlier dialup protocol that PPP supplanted SLIP protokol PPP dialup sebelumnya yang digantikan
RADIUS RADIUS
Diameter Diameter
PPPoA PPPoA
PPPoE PPPoE
Point-to-Point Protocol daemon (PPPD) Point-to-Point Protocol daemon (pppd)
PPPoX PPPoX
Multiprotocol Encapsulation (MPE) for MPEG transport stream Multiprotocol Encapsulation (MPE) untuk transport stream MPEG
Unidirectional Lightweight Encapsulation (ULE) for MPEG transport stream Searah Ringan Enkapsulasi (Ule) untuk transport stream MPEG
[ edit ] References [ sunting ] Referensi [ edit ] External links [ sunting ] Pranala luar PPP animation PPP animasi
Retrieved from " http://en.wikipedia.org/w/index.php?title=Point-to-point_protocol&oldid=473369993 " Diperoleh dari " http://en.wikipedia.org/w/index.php?title=Point-to-point_protocol&oldid=473369993 "
View page ratingsRate this page
Rate this page
Page ratings
What's this?Current average ratings.
Trustworthy

Objective

Complete

Well-written

I am highly knowledgeable about this topic (optional)
I have a relevant college/university degreeIt is part of my professionIt is a deep personal passionThe source of my knowledge is not listed here I would like to help improve Wikipedia, send me an e-mail (optional) We will send you a confirmation e-mail. We will not share your e-mail address with outside parties as per our feedback privacy statement.Submit ratings

Saved successfullyYour ratings have not been submitted yetYour ratings have expiredPlease reevaluate this page and submit new ratings.
An error has occured. Please try again later.
Thanks! Your ratings have been saved.Please take a moment to complete a short survey.Start surveyMaybe later
Thanks! Your ratings have been saved.Do you want to create an account?An account will help you track your edits, get involved in discussions, and be a part of the community.Create an accountorLog inMaybe later
Thanks! Your ratings have been saved.Did you know that you can edit this page?Edit this pageMaybe later Categories : Kategori : Link protocols Link protokol Logical Link Control Logical Link Control Internet standards Standar Internet Modems Modem Hidden categories: Tersembunyi kategori: Articles lacking in-text citations from November 2011 Artikel kurang dalam teks kutipan dari November 2011 All articles lacking in-text citations Semua artikel kurang dalam teks kutipan Articles to be merged from January 2012 Artikel untuk digabung dari Januari 2012 All articles to be merged Semua artikel yang akan digabung All articles with unsourced statements Semua artikel dengan pernyataan unsourced Articles with unsourced statements from September 2009 Artikel dengan pernyataan unsourced dari September 2009

Sunday, January 29, 2012

VCD

Bagian-Bagian VCD Player ,
Sistem kerja vcd player.

Mekanik VCD Player.


Optic VCD PLayer .




Drive Unit VCD Player.




MPEG VCD Player.
Yang selama ini tidak pernah melihat komponen vcd player inilah gambarnya. silahkan dipelajari........

Dasar Elektronika

Dalam kehidupan sehari-hari kita banyak menemui suatu alat yang mengadopsi elektronika sebagai basis teknologinya contoh ; Dirumah, kita sering melihat televisi, mendengarkan lagu melalui tape atau CD, mendengarkan radio, berkomunikasi dengan telephone. Dikantor kita menggunakan komputer, mencetak dengan printer, mengirim pesan dengan faximile, berkomunikasi dengan telephone. Dipabrik kita memakai alat deteksi, mengoperasikan robot perakit, dan sebagainya. Bahkan dijalan raya kita bisa melihat lampu lalu-lintas, lampu penerangan jalan yang secara otomatis hidup bila malam tiba, atau papan reklame yang terlihat indah berkelap-kelip dan masih banyak contoh yang lainnya. Dari semua uraian diatas kita dapat membuktikan bahwa pada zaman sekarang ini kita tidak akan lepas dari perangkat yang menggunakan elektronika sebagai dasar teknologinya.

Revolusi besar-besaran terhadap elektronika terjadi sekitar tahun 1960-an, dimana saat itu mulai ditemukan suatu alat elektronika yang dinamakan Transisor, sehingga dimungkinkan untuk membuat suatu alat dengan ukuran yang kecil dimana sebelumnya alat-alat tersebut masih menggunakan tabung-tabung facum yang ukurannya besar serta mengkonsumsi listrik yang besar. Hanya dalam kurun waktu 10 tahun sejak ditemukan nya transistor, ditemukan sebuah rangkaian terintegrasi yang dikenal dengan IC ( Integrated Circuit ) merupakan sebuah rangkaian terpadu yang berisi puluhan bahkan jutaan transistor di dalamnya. Sehingga kita bisa melihat sebuah perangkat elektronika semakin kecil bentuknya tetapi semakin banyak fungsinya sebagai contoh telephone genggam ( Handphone ) yang anda pakai saat ini dengan telephone genggam yang anda pakai beberapa tahun yang lalu. Yah semua itu berkat revolusi Silikon sebagai bahan dasar pembuatan Transistor dan IC atau CHIP.

Baiklah, sampai disini saja gembar-gembor kita mengenai perkembangan elektronika. Tentunya anda sudah tidak sabar lagi ingin segera mempelajari teknologi elektronika, tapi bagi anda yang masih ingin mengetahui sejarah perkembangan elektronika anda bisa mencarinya dari berbagi sumber lain.

I. KOMPONEN ELEKTRONIKA - RESISTOR
Resistor adalah komponen elektronika yang selalu digunakan dalam setiap rangkaian elektronika karena dia berfungsi sebagai pengatur arus listrik. Dengan resistor listrik dapat didistribusikan sesuai dengan kebutuhan. Tentunya anda bertanya-tanya, apa itu resistor ?, seperti apa bentuknya ?, bagaimana cara kerjanya ?, oops..., nanti dulu saya baru akan menjelaskannya.


Ilustrasi Arus Air untuk mengetahui cara kerja Resistor

Setelah anda perhatikan animasi tadi, tentunya anda sudah mempunyai gambaran tentang bagaimana prinsip kerja dari sebuah resistor. Yah anda anggap saja arus air yang ada di animasi itu sebagai arus listrik, sedangkan bendungan sebagai resistornya. Jadi bila bendungan 1 kita anggap sebagai resistor 1 dan bendungan 2 sebagai resistor 2, maka besarnya arus tergantung dari besar kecilnya pintu bendungan yang kita buka. Semakin besar kita membuka pintu bendungan semakin besar juga arus yang melewati bendungan tersebut bila ingin lebih besar lagi arusnya, yah tidak usah dipasang bendungannya atau dibiarkan saja, jadi bila kita menginginkan arus yang besar maka kita pasang resistor yang nilai resistansi ( tahanan ) nya kecil, mendekati nol atau sama dengan nol atau tidak dipasang sama sekali dengan demikian arus tidak lagi dibatasi. Nah seperti itulah kira-kira fungsi Resistor dalam sebuah rangkaian elektronika.

Suatu fungsi dalam dunia teknik tentunya mempunyai satuan atau besaran, misalnya untuk berat kita tahu bahwa pada umumnya satuannya adalah "gram", satuan jarak pada umumnya orang memakai satuan " meter ". Nah untuk resistor satuannya adalah OHM, jadi mulai sekarang kita biasakan untuk menyebut besarnya nilai suatu resistor atau tahanan kita gunakan satuan OHM, yang sebenarnya berasal dari kata OMEGA. Maka tidaklah heran bila lambang dari OHM berbentuk seperti tapal kuda orang yunani menyebutnya omega entah kenapa demikian saya juga kurang paham karena saya bukan ahli sejarah he he he . Ok, jadi bila nanti anda melihat rangkaian elektronika lalu disitu tertulis misalnya 470 maka itu adalah sebuah resistor dengan nilai 470 OHM.., paham..!!.

Didalam rangkaian elektronika resistor dilambangkan dengan angka " R " , sedangkan icon nya seperti ini : . Ada beberapa jenis resistor yang ada dipasaran antara lain : Resistor Carbon, Wirewound, dan Metal Film. Ada juga Resistor yang dapat diubah-ubah nilai resistansinya antara lain : Potensiometer dan Trimpot. Selain itu ada juga Resistor yang nilai resistansinya berubah bila terkena cahaya namanya LDR ( Light Dependent Resistor ) dan Resistor yang yang nilai resistansinya berubah tergantung dari suhu disekitarnya namanya NTC ( Negative Thermal Resistance ) agar lebih jelas coba anda perhatikan gambar 1-a, dan animasi berikut ini :


Prinsip Dasar, Cara Kerja Sebuah LDR


Berbagai Jenis type dan bentuk Resistor


Potensiometer L D R N T C Trimpot
Lambang-lambang dari beberapa Jenis Resistor

Hmmm..., bagaimana friend !. Saya rasa sampai disini anda sudah memahami prinsip kerja dari resisor. Sekarang mari kita lanjutkan dengan materi yang lain.

Untuk resistor jenis carbon maupun metalfilm biasanya digunakan kode-kode warna sebagai petunjuk besarnya nilai resistansi ( tahanan ) dari resistor. Kode-kode warna itu melambangkan angka ke-1, angka ke-2, angka perkalian dengan 10 ( multiflier ), nilai toleransi kesalahan, dan nilai qualitas dari resistor. Kode warna itu antara lain Hitam, Coklat, Merah, Orange, Kuning, Hijau, Biru, Ungu, Abu-abu, Putih, Emas dan Perak. ( lihat gambar 1-b dan tabel 1 ). Warna hitam untuk angka 0, coklat untuk angka 1, merah untuk angka 2, orange untuk angka 3, kuning untuk angka 4, hijau untuk angka 5, biru untuk angka 6, ungu untuk angka 7, abu-abu untuk angka 8, dan putih untuk angka 9. Sedangkan warna emas dan perak biasanya untuk menunjukan nilai toleransi yaitu emas nilai toleransinya 10 %, sedangkan perak nilai toleransinya 5 %.

Wah banyak sekali sulit untuk menghafalnya..!, hmmm.., kalau anda merasa kesulitan menghafal kode warna dari resistor beserta nilainya, coba perhatikan teks yang saya beri huruf tebal diatas. Kalau disatukan akan menjadi sebuah kata yang mungkin mudah bagi anda untuk menhafalnya ( Hi Co Me O Ku Hi B U A P == 0 1 2 3 4 5 6 7 8 9 ). Ok sekali lagi coba anda lihat gambar 1-b dan tabel 1

KODE WARNA APPLET WARNA NILAI TOLERANSI
Hitam 0 -----
Coklat 1 -----
Merah 2 -----
Orange 3 -----
Kuning 4 -----
Hijau 5 -----
Biru 6 -----
Ungu 7 -----
Abu-abu 8 -----
Putih 9 -----
Emas 0,1 10 %
Perak 0,01 1 %

Nah sekarang mari kita mencoba membaca nilai suatu resistor. Misalkan anda melihat sebuah resistor dengan kode warna sebagai berikut : Coklat, merah, merah, dan emas. Berapa nilai resistansi dari resistor tersebut..?. ( Perlu diingat..! : Untuk membaca angka pertama dari kode warna resistor anda harus melihat warna yang paling dekat dengan ujung sebuah resistor dan biasanya untuk angka ke-1,2 dan 3 saling berdekatan sedangkan untuk kode warna dari toleransi agak jauh dari warna-warna yang lain, sekali lagi lihat gambar 1-b dan tabel 1

Untuk membaca kode warna resistor seperti yang dipermasalahkan diatas, kita mulai menerjemahkan satu persatu kode tersebut. Warna pertama Coklat, berarti angka 1, warna kedua warna merah, berarti angka 2, warna ketiga warna merah berarti multiflier, perkalian dengan 10 pangkat 2. kalau diterjemahkan 12 X 10 2 = 12 X 100 = 1200. Berarti 1200 Ohm. dengan nilai toleransi sebesar 10 %. Akurasi dari resistor tersebut berarti 1200 X ( 10 : 100 ) = 1200 X ( 1 : 10 ) = 120. ( he he he, itulah ilmu exacta selalu berhubungan dengan matematika yupsss, padahal saya juga pusing nih ngitung-ngitung yang ginian, ha ha ha.. selingan aja ) jadi nilai sebenarnya dari resistor tersebut adalah maximum 1200 + 120 = 1320 Ohm, sedangkan nilai minimum nya adalah 1200 - 120 = 1080 Ohm. Kenapa demikian ...?. Karena karakteristik dari bahan baku resistor tidak sama, walaupun pabrik sudah mengusahakan agar dapat menjadi standart tetapi apa daya prosesnya menjadi tidak standart. Untuk itulah pabrik menyantumkan nilai toleransi dari sebuah resistor agar para designer dapat memperkirakan seberapa besar faktor x yang harus mereka fikirkan agar menghasilkan yang mereka kehendaki.

Sekarang coba saya kasih soal lalu anda cari nilai nya sendiri, ( buat PR . he he he..., kayak anak SD aja ). Soalnya begini : Didalam sebuah rangkaian saya melihat sebuah resistor jenis carbon dengan warna-warna sebagai berikut ; Merah, Kuning, Hijau dan Perak. Berapa nilai minimum dari resistor tersebut ?.

Di dalam praktek para designer sering kali membutuhkan sebuah resistor dengan nilai tertentu. Akan tetapi nilai resistor tersebut tidak ada di toko penjual, bahkan pabrik sendiri tidak memproduksinya. Lalu bagaimana solusinya..?. Nah...!, seperti yang pernah saya singgung diatas bahwa ilmu exacta selalu berhubungan dengan matematika, maka untuk mendapatkan suatu nilai resistor dengan resistansi yang unik dapat dilakukan dua cara ; Pertama cara SERIAL, dan yang kedua cara PARALEL. ( Wah.., nambah pusing lagi nih..! ). Dengan cara demikian maka masalah designer diatas dapat terpecahkan. Bagaimana cara Serial dan bagaimana pula cara Paralel, untuk lebih jelasnya coba anda perhatikan gambar 1-d.



Cara memasang Resistor cara Serial dan Paralel

Dengan Cara tersebut suatu nilai resistor dapat menjadi unik. Lalu bagaimana menghitungnya ?, Ehmm. mudah saja, untuk cara serial anda tinggal menambahkan saja nilai resistor 1 dan nilai resistor 2. ( R1 + R2 ) . Sedangkan untuk cara paralel anda dituntut untuk mengerti ALJABAR ( wah-wah lagi-lagi matematika ) tapi mudah kok. Kalau ingin mahir Matematika buka saja topik yang membahas khusus tentang matematika di situs ini juga. Ok kembali ke permasalahan. Untuk cara paralel ditentukan rumus sebagai berikut : misalkan kita memparalel dua buah resistor, resistor pertama diberi nama R1 dan resistor kedua diberi nama R2, maka rumusnya adalah : 1/R= ( 1/R1 ) + ( 1/R2 )

Contoh : Kita mempunyai dua buah resistor dengan nilai berikut R1=1000 Ohm , R2=2000 Ohm, bila kita menggunakan cara serial maka didapat hasil R1+R2 1000+2000 = 3000 Ohm, sedangkan bila kita menggunakan cara Paralel maka didapat hasil :

1 / R = 1 / R1 + 1 / R2
1 / R = (1/1000) + (1/2000)
1 / R = (2000 + 1000) / (1000 X 2000)
1 / R = (3000) / (2000000)
1 / R = 3 / 2000
3R = 2000
R = 2000 / 3
R = 666,7 Ohm -----> Resistor Hasil Paralel.

silahkan buktikan sendiri dengan persamaan aljabar dalam matematika.

Matkul smester 2

UNI 121 KWARGNGARAAN 2SKS
TEK 122 FISDAS II 3SKS
UNI 122 ILMU BDAYA N SOSIAL DASAR 2SKS
TEK 123 KMIA DASAR 2SKS
TEK 121 KLKULUS II 3SKS
... TEI 121 DSAR SSTEM INFRMSI 2SKS
TEI 122 RNGKAIAN LSTRIK I 3SKS
TEI 123 DSAR ELEKTRONIKA 2SKS
TEK 124 PRAK.FISDAS II 1SKS
TEI 124 PRAK.DSAR ELEKTRNIKA 1SKS

Saturday, January 28, 2012

email h1

h1 { color: red }
Selama ini tentunya Anda telah mengenal tiga jenis layanan email, yaitu POP mail, email forwarding dan email berbasis web. Masing-masing jenis email tersebut mempunyai kelebihan dan kekurangan.

POP Mail
Email jenis ini sama dengan email yang Anda terima dari ISP Anda (bagi Anda yang connect internet dari rumah atau kantor).

Kelebihan :
Kelebihan utama POP mail adalah kemampuannya untuk dibaca secara offline (tidak connect ke internet). Untuk mengecek email, Anda perlu connect ke server POP mail Anda, lalu mendownload seluruh email yang ada. Setelah itu Anda bisa memutuskan hubungan dengan internet dan membaca email. Bila sudah siap dengan jawabannya Anda bisa connect lagi ke internet dan tekan Send. Untuk itu semua Anda harus menggunakan program client mail seperti Eudora atau Outlook Express.

Kekurangan
Kekurangan POP mail adalah Anda tidak bisa mengecek email Anda dari sembarang tempat.

Web Based email
Email jenis ini merupakan email yang ditawarkan berbagai situs seperti Yahoo, Hotmail, BolehMail, LoveMail dan lain-lain.

Kelebihan
Anda bisa mengecek email Anda dari mana saja dan browser apa saja.

Kekurangan
Kekurangan utama dari email berbasis web adalah, untuk mengecek email Anda harus selalu terhubung ke internet. Bagi yang hanya menerima beberapa atau belasan email tentu nggak begitu terasa. Tapi bagi Anda yang menerima puluhan email atau bahkan ratusan email tentu akan terasa kekurangannya terutama dalam hal biaya (menambah biaya, karena harus selalu connect ke internet).

Email Forwarding
Email jenis ini akan terasa manfaatnya bagi Anda yang belum menemukan layanan email yang cocok alias suka gonta-ganti email. Pada prinsipnya email forwarding ini merupakan layanan email yang meneruskan email yang dikirim kepadanya ke account email Anda yang lain.

Kelebihan
Anda bisa menyembunyikan alamat email Anda yang sesungguhnya. Selain itu Anda juga tidak perlu memberi tahu email Anda yang baru (jika Anda sering gonta-ganti email). Yang Anda berikan cukup alamat email forwarding tersebut.

Kekurangan
Karena bersifat sebagai perantara, email tersebut akan membutuhkan waktu yang lebih lama untuk sampai ke tempat Anda.

email

Selama ini tentunya Anda telah mengenal tiga jenis layanan email, yaitu POP mail, email forwarding dan email berbasis web. Masing-masing jenis email tersebut mempunyai kelebihan dan kekurangan.

POP Mail
Email jenis ini sama dengan email yang Anda terima dari ISP Anda (bagi Anda yang connect internet dari rumah atau kantor).

Kelebihan :
Kelebihan utama POP mail adalah kemampuannya untuk dibaca secara offline (tidak connect ke internet). Untuk mengecek email, Anda perlu connect ke server POP mail Anda, lalu mendownload seluruh email yang ada. Setelah itu Anda bisa memutuskan hubungan dengan internet dan membaca email. Bila sudah siap dengan jawabannya Anda bisa connect lagi ke internet dan tekan Send. Untuk itu semua Anda harus menggunakan program client mail seperti Eudora atau Outlook Express.

Kekurangan
Kekurangan POP mail adalah Anda tidak bisa mengecek email Anda dari sembarang tempat.

Web Based email
Email jenis ini merupakan email yang ditawarkan berbagai situs seperti Yahoo, Hotmail, BolehMail, LoveMail dan lain-lain.

Kelebihan
Anda bisa mengecek email Anda dari mana saja dan browser apa saja.

Kekurangan
Kekurangan utama dari email berbasis web adalah, untuk mengecek email Anda harus selalu terhubung ke internet. Bagi yang hanya menerima beberapa atau belasan email tentu nggak begitu terasa. Tapi bagi Anda yang menerima puluhan email atau bahkan ratusan email tentu akan terasa kekurangannya terutama dalam hal biaya (menambah biaya, karena harus selalu connect ke internet).

Email Forwarding
Email jenis ini akan terasa manfaatnya bagi Anda yang belum menemukan layanan email yang cocok alias suka gonta-ganti email. Pada prinsipnya email forwarding ini merupakan layanan email yang meneruskan email yang dikirim kepadanya ke account email Anda yang lain.

Kelebihan
Anda bisa menyembunyikan alamat email Anda yang sesungguhnya. Selain itu Anda juga tidak perlu memberi tahu email Anda yang baru (jika Anda sering gonta-ganti email). Yang Anda berikan cukup alamat email forwarding tersebut.

Kekurangan
Karena bersifat sebagai perantara, email tersebut akan membutuhkan waktu yang lebih lama untuk sampai ke tempat Anda.

Friday, January 27, 2012

CMS

CMS (Content Management System){ July 9, 2011 @ 8:35 am } · { Campuran, Pengetahuan }
{ Tags: CMS (Content Management System), Contoh CMS, Pengertian CMS } · { Leave a Comment }

CMS adalah perangkat lunak yang memungkinkan seseorang untuk menambahkan dan/atau memanipulasi (mengubah) isi dari suatu situs Web.

Beberapa pengertian dan kegunaan CMS:
1. CMS Portal
Web Portal adalah web yang memiliki kelebihan program aplikasi yang lengkap, seperti program untuk mengatur berita, polling, komentar pengunjung, pengaturan artikel, forum diskusi, buku tamu, iklan baris, dan sebagainya.
Tool ini memudahkan kita untuk memanage berita, artikel, tulisan dan mengumpulkan pendapat (polling). Contoh sebuah portal adalah detik.com.
Produk CMS: Endonesia dan memht

2. CMS Blogs
Blog adalah kependekan dari Weblog. Pada awalnya, istilah Weblog dipakai untuk menyebut website pribadi yang diupdate secara kontinyu, berisi daftar link yang dianggap menarik disertai komentar-komentar mereka sendiri.
Produk CMS:WordPress, Joomla, pivotx

3. CMS E-Commerce
E-Commerce didefinisikan sebagai proses pembelian dan penjualan produk, jasa dan informasi yang dilakukan secara elektronik dengan memanfaatkan jaringan komputer.
Produk CMS: osCommerce, phpShop, dan Zen Cart.

4. CMS Forums
Forum adalah tool tempat diskusi, dimana kita dapat berdiskusi melalui Web. Biasanya di Forum kita berdiskusi mengenai topik apa saja atau tertentu.
Produk CMS: SMF (Simple Machine Forum) dan phpBB

5. CMS E-Learning
E-Learning adalah bentuk pembelajaran berbasis web yang bisa diakses dari intranet di jaringan lokal atau internet.
Produk CMS: Dokeos, Moodle, dan Site@School.

7. CMS Wiki
Wiki adalah tool untuk membangun naskah secara kolaboratif, hingga dapat menjadi ensiklopedia di Internet.
Produk CMS: MediaWiki, phpWiki, TikiWiki